#3579 closed Bug (fixed)

Reprocessing logs doesn't regenerati weekly values

Reported by: paolobenve Owned by:
Priority: normal Milestone: 1.10 - Piwik 1.10
Component: Core Keywords:
Cc: Sensitive: no

Description

Piwik 1.9.2

As recommended in http://piwik.org/faq/how-to/#faq_59 , I deleted all piwik_archive_* tables with phpmyadmin in order to take into account the geoip data I have in consecuence of the installation of pecl geoip extension.

After some hours I could see that all the logs are regenerated (I have a cron job running every 15 minutes), except for the weekly ones: in the "Evolution over the period" graph I have data > 0 only for the last two weeks; all the preceeding weeks show 0 value.

Instead, the daily, monthly and weekly data are regenerated correctly

Change History (2)

comment:1 Changed 17 months ago by paolobenve

I tried again from the command line, deleting the db tables and running again the command

$ sudo -u www-data /usr/bin/php5 /var/www/piwik/misc/cron/archive.php --url=http://my.server.org/piwik/  --force-all-websites --force-all-periods=10000

it ran without errors on all my 14 websites (2 of them have about 2.000 and 20.000 daily visits), and I got everything but weekly reports fine: weekly data are reprocessed for no more than the last 52 weeks. Older weekly data are all zero.

comment:2 Changed 16 months ago by matt (mattab)

  • Milestone set to 1.9.3 - Piwik 1.9.3
  • Resolution set to fixed
  • Status changed from new to closed

Thanks for the report, Fixed in [7594]

Note: See TracTickets for help on using tickets.