Opened 15 months ago

Closed 15 months ago

Last modified 15 months ago

#3678 closed Bug (fixed)

archive.php failing on GeoIP Update in 1.10.1

Reported by: thingles Owned by:
Priority: normal Milestone:
Component: Core Keywords: GeoIP
Cc: Sensitive: no

Description

I upgraded to 1.10.1 last night and I setup automatic updating for my geo location database using the suggested URL. Last night when archive.php ran it generated the following errors (note, I changed my filesystem path)

SCHEDULED TASKS
Starting Scheduled tasks... 
ERROR: Got invalid response from API request: http://stats.thingelstad.com/index.php?module=API&method=CoreAdminHome.runScheduledTasks&format=csv&convertToUnicode=0&token_auth=c2a0c68752275b18010b1d93ae97b977&trigger=archivephp. Response was 'task,output
Piwik_PDFReports.dailySchedule,Time elapsed: 1.106s
Piwik_UserCountry_GeoIPAutoUpdater.update,ERROR: Piwik_UserCountry_GeoIPAutoUpdater: failed to download '' to '/path/to/piwik/public_html/misc/GeoIPISP.dat.': curl_exec: <url> malformed'

done
---------------------------
SUMMARY OF ERRORS
Error: Got invalid response from API request: http://stats.thingelstad.com/index.php?module=API&method=CoreAdminHome.runScheduledTasks&format=csv&convertToUnicode=0&token_auth=c2a0c68752275b18010b1d93ae97b977&trigger=archivephp. Response was 'task,output
Piwik_PDFReports.dailySchedule,Time elapsed: 1.106s
Piwik_UserCountry_GeoIPAutoUpdater.update,ERROR: Piwik_UserCountry_GeoIPAutoUpdater: failed to downl
1 total errors during this script execution, please investigate and try and fix these errors
ERROR: 1 total errors during this script execution, please investigate and try and fix these errors. First error was: Got invalid response from API request: http://stats.thingelstad.com/index.php?module=API&method=CoreAdminHome.runScheduledTasks&format=csv&convertToUnicode=0&token_auth=c2a0c68752275b18010b1d93ae97b977&trigger=archivephp. Response was 'task,output
Piwik_PDFReports.dailySchedule,Time elapsed: 1.106s
Piwik_UserCountry_GeoIPAutoUpdater.update,ERROR: Piwik_UserCountry_GeoIPAutoUpdater: failed to downl
PHP Fatal error:  1 total errors during this script execution, please investigate and try and fix these errors. First error was: Got invalid response from API request: http://stats.thingelstad.com/index.php?module=API&method=CoreAdminHome.runScheduledTasks&format=csv&convertToUnicode=0&token_auth=c2a0c68752275b18010b1d93ae97b977&trigger=archivephp. Response was 'task,output
Piwik_PDFReports.dailySchedule,Time elapsed: 1.106s
Piwik_UserCountry_GeoIPAutoUpdater.update,ERROR: Piwik_UserCountry_GeoIPAutoUpdater: failed to downl in /path/to/piwik/public_html/misc/cron/archive.php on line 566

At first I thought the update of the city database failed, but that worked fine. Actually, Piwik was attempting to update the ISP data which I haven't provided a link for, and I don't think is available without paying.

Screenshot of my settings attached.

Attachments (1)

screenshot.png (101.8 KB) - added by thingles 15 months ago.

Download all attachments as: .zip

Change History (6)

Changed 15 months ago by thingles

comment:1 Changed 15 months ago by thingles

Crap. Just noticed that output had my auth token in it and I can't edit the post... ugh.

comment:2 Changed 15 months ago by thingles

Changed my password and auth_token. Wont make the mistake of posting that again. :-\

comment:3 Changed 15 months ago by capedfuzz (diosmosis)

  • Resolution set to fixed
  • Status changed from new to closed

(In [7776]) Fixes #3678, use !empty instead of !== false when checking if GeoIP URL is saved.

comment:4 Changed 15 months ago by matt (mattab)

Thanks for the report. when you open this URL in your browser with the correct token, what is the full errror message?

comment:5 Changed 15 months ago by thingles

It looks like the issue is closed now. FWIW, this seems to have just happened the one time. It hasn't happened again.

Note: See TracTickets for help on using tickets.