#3683 closed Bug (fixed)

Dashboard doesn't show "related report" data for date ranges

Reported by: themilkman Owned by:
Priority: normal Milestone: 1.11 - Piwik 1.11
Component: Core Keywords: related report, time period
Cc: Sensitive: no

Description

See this forum post
http://forum.piwik.org/read.php?2,99579,99626#msg-99626

On the attached screenshot you can see that showing data for time periods doesn't work. Simply choose a time period and then click on "related report: ..". No data will be shown. Additionally switching back to normal browser data doesn't show any data anymore afterwards. I had the same issue for related reports to operation systems.

On my own piwik installation I got an error/exception as posted in the forum entry. In the demo I do not get this but as mentioned before it there seems to be an error.

Attachments (1)

piwik.png (225.9 KB) - added by themilkman 15 months ago.
shows no data available for time period

Download all attachments as: .zip

Change History (4)

Changed 15 months ago by themilkman

shows no data available for time period

comment:1 Changed 15 months ago by matt (mattab)

  • Summary changed from Dashboard doesn't show "related report" data for time periods to Dashboard doesn't show "related report" data for date ranges

thanks for the report. NOte: it works in sub-reports and fails only on dashboard.

comment:2 Changed 15 months ago by matt (mattab)

  • Milestone set to 1.11 - Piwik 1.11

comment:3 Changed 15 months ago by capedfuzz (diosmosis)

  • Resolution set to fixed
  • Status changed from new to closed

(In [7775]) Fixes #3683, decode URI parameters in related report JS after parsing URL.

Note: See TracTickets for help on using tickets.