#3742 closed Bug (fixed)

Display of browser versions fails when filtering by date range

Reported by: byteconsult-it Owned by:
Priority: normal Milestone: 1.12 - The Great 1.x Backlog
Component: Core Keywords:
Cc: Sensitive: no

Description

We are tracking visitors at our site since yesterday. I can successfully view browser and browserversion stats initially (data is filtered by default by current week).

However, when I selected to display data from yesterday to today only (date range), the following is observed:

  • initial display of browser stats works
  • clicking "Report browser version" at bottom middle shows a message that no data has been found
  • switching back to original report by clicking the link at bottom middle again shows same message.

Found in 1.8.1 and 1.10.1

Change History (4)

comment:1 Changed 15 months ago by matt (mattab)

  • Milestone set to 1.11 - Piwik 1.11

Can you replicate this problem on demo.piwik.org ?
If yes please copy URL here and instructions. Thanks

comment:2 Changed 15 months ago by byteconsult-it

Yes, I can:

  1. Click calendar icon in "Date range:" box at top left
  2. Choose Thu, Feb 07 as "from" and Fri, Feb 08 as "to" date
  3. Click "Apply date range"
  4. In widget "Visitor Browser" click "Related report: Browser version"

=> "There is no data for this report." is displayed instead of browser version details

  1. Click "Related report: Browsers" to switch back to original report

=> "There is no data for this report." is displayed instead of general browser details

comment:3 Changed 13 months ago by SteveG (sgiehl)

Works for me on demo. Might be already fixed. Can anyone confirm?

comment:4 Changed 13 months ago by matt (mattab)

  • Resolution set to fixed
  • Status changed from new to closed

Indeed works in GIT! Nice.

Note: See TracTickets for help on using tickets.