#3783 closed Bug (fixed)

cron archiver curl error - patch attached

Reported by: specky_rum Owned by: mattab
Priority: major Milestone:
Component: Core Keywords:
Cc: Sensitive: no

Description

Hi,

Apologies if this is already reported / fixed, I did look but only found a reference to it having been reported but no fix.

Anyway...

The archiver can fail with newer versions of PHP due to a bug in curl see: https://bugs.php.net/bug.php?id=64177&edit=1

The problem is in the curl_multi_close() function but it only occurs if no handles were opened. Although not a bug in Piwik this is easy to work around and the fix makes the archiver a smidge more efficient too. Patch attached. All it does is to not call curl_multi_init() unless it is actually needed, therefore preventing the problematic calling of curl_multi_close() with no handles.

This bug stopped our archiver from running at all for two weeks and I'm sure we're not the only ones!

Cheers!

Attachments (1)

archive.php.patch (3.4 KB) - added by specky_rum 14 months ago.
patch to get around curl bug

Download all attachments as: .zip

Change History (2)

Changed 14 months ago by specky_rum

patch to get around curl bug

comment:1 Changed 14 months ago by matt (mattab)

  • Owner set to mattab
  • Resolution set to fixed
  • Status changed from new to closed

In 2ffc22b563cc707e107d01b7d197605756f0c1a4:

Fixes #3783 Thanks for the report & patch help

Note: See TracTickets for help on using tickets.