Opened 14 months ago

Closed 14 months ago

Last modified 13 months ago

#3821 closed Bug (fixed)

Scheduled Reports broken, because a report is set to never send (period=never)

Reported by: JulienM Owned by: JulienM
Priority: normal Milestone: 1.12 - The Great 1.x Backlog
Component: Core Keywords:
Cc: Sensitive: no

Description

If a report is set to never send (period=never) the following exception is raised and no report is sent :

Error: period never.is undefined.

Regression was introduced in commit https://github.com/piwik/piwik/commit/76f6a9e5f9d555bbba52435f10513a11ab85b70a while fixing ticket #3706.

Change History (4)

comment:1 Changed 14 months ago by JulienM (JulienMoumne)

  • Owner set to JulienM
  • Status changed from new to assigned

comment:2 Changed 14 months ago by Julien Moumné

  • Resolution set to fixed
  • Status changed from assigned to closed

In c176f8057ef172bc098b289a5daef165a10faf6a:

fixes #3821 do not schedule reports set to never send (period=never)

comment:3 Changed 14 months ago by matt (mattab)

Good one!

comment:4 Changed 13 months ago by matt (mattab)

  • Milestone set to 1.12 - The Great 1.x Backlog
  • Summary changed from Scheduled Reports set to never send (period=never) break all reports to Scheduled Reports broken, because a report is set to never send (period=never)
Note: See TracTickets for help on using tickets.