#3869 closed Bug (fixed)

latest upgrade file permissions incorrect causing server 500

Reported by: nisiwi Owned by:
Priority: normal Milestone: 1.12 - The Great 1.x Backlog
Component: Core Keywords: server 500, file permissions
Cc: Sensitive: no

Description

Latest upgrade to piwik 1.11.1 had file permissions that caused piwik to trigger a server 500 error.

Setting file permission to 644 ot 755 resolves the problem.

Related forums threads;

http://forum.piwik.org/read.php?2,102540,102570
http://forum.piwik.org/read.php?2,102448

Change History (2)

comment:1 Changed 13 months ago by matt (mattab)

  • Milestone set to 1.12 - The Great 1.x Backlog

Thanks for the report. The problem is

The permissions on the files (not folders or directories) are not set correctly.
Simply change all the file permissions from 664 to 644 in the piwik main directory. Then you are done. 

That's interesting. Maybe it is a side effect of GIT migration.

I see that the files have 664 in GIT. When i chmod to 644, and then do "git status" the filemode change does not appear. I also tried:

$ git config core.filemode true

So I'm not sure, how we go to modify these file permissions back to 644 in git?

IDEAL Solution: Maybe the ideal fix is to recursively convert all PHP files in Piwik to 644 permission?

Last edited 13 months ago by matt (previous) (diff)

comment:2 Changed 13 months ago by matt (mattab)

  • Resolution set to fixed
  • Status changed from new to closed

Could you please try with all files from the latest beta, I tried to change umask to 0022 which should fix it. Thanks Fabian for the hint! http://builds.piwik.org/piwik-1.12-b5.zip

Note: See TracTickets for help on using tickets.