#3877 closed New feature (fixed)

Invite users to upgrade to php 5.3 to enjoy upcoming Piwik 2.0

Reported by: matt Owned by: diosmosis
Priority: major Milestone: 1.12 - The Great 1.x Backlog
Component: UI - UX (AngularJS, twig, less) Keywords:
Cc: Sensitive: no

Description (last modified by matt)

If detected PHP version is less than 5.3:

  • Display at all time in the admin screen a yellow notice bar
  • proposed text: "We are working on the next generation Piwik to provide you with a much enhanced Web Analytics platform! Piwik 2.0 will require PHP 5.3 so please ask your server administrator or web hosting provider to update your PHP to the latest version, ideally PHP 5.4. <br/> When you upgrade to PHP 5.3 or 5.4, this message box will disappear and your Piwik server will process reports much faster using less memory. Please update PHP to get the most out of Piwik!"

This notice is meant to teach users about speed+memory advantages of upgrading + maintaining users within the piwik requirements by warning about future requirement that they can prepare at least for 3-4 months.

Change History (2)

comment:1 Changed 13 months ago by matt (mattab)

  • Description modified (diff)

updating text per Benaka suggestions

comment:2 Changed 12 months ago by capedfuzz (diosmosis)

  • Owner set to diosmosis
  • Resolution set to fixed
  • Status changed from new to closed

In f94aef3d89bdde4cbe04c24a5c10c6f63c8c6fb7:

Fixes #3877, add warning message that is displayed if a user's PHP version is less than 5.3.

Note: See TracTickets for help on using tickets.