Opened 13 months ago

Closed 10 months ago

Last modified 10 months ago

#3884 closed Bug (fixed)

Report Visits Summary, Weekly report shows last Day's summary

Reported by: jarmstrong Owned by: halfdan
Priority: normal Milestone: 1.12 - The Great 1.x Backlog
Component: Core Keywords:
Cc: Sensitive: no

Description

The weekly reports option now are reporting as Days instead of Weeks. Additionally the Visitors summary is showing the summary for only the last day in the report.

This was introduced in 1.11.x and after searching other bugs I could not find a related item.

Change History (6)

comment:1 Changed 13 months ago by jarmstrong

With additional research it appears that 1.11.1 is not respecting the Week period specified and always used the Day. When I adjust the API.php file to force the week period the report generates without a problem.

comment:2 Changed 13 months ago by halfdan

  • Owner set to halfdan
  • Status changed from new to assigned

comment:3 Changed 13 months ago by Fabian Becker

  • Resolution set to fixed
  • Status changed from assigned to closed

In e3096c0359dd6ab23680c7224a1e0144fae86f1b:

Use correct period when manually generating reports.

fixes #3884

comment:4 Changed 10 months ago by matt (mattab)

  • Resolution fixed deleted
  • Status changed from closed to reopened

It is actually by design, that you can generate the reports for whatever period is currently selected. Reverting

comment:5 Changed 10 months ago by matt (mattab)

  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.