Opened 11 months ago

Closed 6 months ago

Last modified 6 months ago

#3970 closed Bug (fixed)

API method API.getBulkRequest converts whitespace to HTML entities

Reported by: tsteur Owned by: tsteur
Priority: normal Milestone: 2.0 - Piwik 2.0
Component: Core Keywords:
Cc: Sensitive: no

Description

Hi,

I'm displaying some properties from Live.getLastVisitDetails in Mobile App. When requesting this method via BulkRequests, it converts some content to HTML entities.

timeSpentPretty: "2 min 8s"

For instance visitDurationPretty and timeSpentPretty . I cannot reproduce this behavior when executing plain Live.getLastVisitDetails action (no BulkRequest).

In Mobile App I cannot resolve HTML entities. Can we either not convert anything or convert them to Unicode (\u0000)?

Plain request (replace token_auth to reproduce):
http://demo.piwik.org/?module=API&method=Live.getLastVisitsDetails&idSite=1&period=day&date=today&format=JSON&token_auth=XXXXXXX

With BulkRequest (replace token_auth to reproduce):
http://demo.piwik.org/index.php?urls%5B0%5D=method%3dLive.getCounters%26lastMinutes%3d30%26format%3dJSON%26idSite%3d1%26&urls%5B1%5D=method%3dLive.getCounters%26lastMinutes%3d1440%26format%3dJSON%26idSite%3d1%26&urls%5B2%5D=method%3dLive.getLastVisitsDetails%26filter_limit%3d20%26period%3dday%26date%3dtoday%26format%3dJSON%26idSite%3d1%26&module=API&date=today&token_auth=XXXXXXXXXX&period=day&format=json&method=API.getBulkRequest&language=en&

Change History (10)

comment:1 Changed 11 months ago by matt (mattab)

I know this is not an acceptable answer :p but what about such function? http://stackoverflow.com/questions/5796718/html-entity-decode/9609450#9609450

comment:2 Changed 11 months ago by tsteur

Yes, not acceptable :) I do not have a DOM in native mobile app ;) And we should avoid as much computation on mobile as possible ;)

comment:3 Changed 10 months ago by matt (mattab)

  • Milestone set to 2.0 - Piwik 2.0
  • Priority changed from normal to major

comment:4 Changed 7 months ago by matt (mattab)

  • Owner set to tsteur
  • Priority changed from major to normal

comment:5 Changed 7 months ago by matt (mattab)

  • Milestone changed from 2.0 - Piwik 2.0 to Piwik 2.1

Piwik 2.0 full focus mode: Moving normal + low priorities to Piwik 2.1 milestone.

comment:6 Changed 6 months ago by matt (mattab)

  • Milestone changed from 2.1 - Piwik 2.1 to 2.0 - Piwik 2.0

comment:7 Changed 6 months ago by tsteur

In 229e04cdd54e50cba6aee2b5b4b46881b166e8f0:

refs #3970 this should fix html entities are returned in json output

comment:8 Changed 6 months ago by tsteur

  • Resolution set to fixed
  • Status changed from new to closed

comment:9 Changed 6 months ago by tsteur

In 9206f7d2639e2a6a279f000f772962e08cf17fcc:

refs #3970 this should fix some bulk requests are not correct rendered because there is an array of dataTables

comment:10 Changed 6 months ago by tsteur

In 68b8ccb4b1321cfc46ef3ca432a38c63afd6a449:

refs #3970 probably a better fix for html entities in json output, fixes bulkRequest is buggy with PHP and other renderers

Note: See TracTickets for help on using tickets.