Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#510 closed Bug (fixed)

Update to jquery 1.3.x, jqueryUI 1.7.x

Reported by: vipsoft Owned by: vipsoft
Priority: major Milestone: Piwik 0.5
Component: UI - UX (AngularJS, twig, less) Keywords:
Cc: Sensitive: no

Description (last modified by vipsoft)

As a follow-up to #243, we did not update some ui plugins. jquery 1.3 was released this past week, and jqueryUI 1.6 is reportedly around the corner (it slipped its Dec 2008 release target).

Change History (20)

comment:1 Changed 5 years ago by vipsoft (robocoder)

  • Milestone changed from Surviving The Wild to Features requests - after Piwik 1.0

comment:2 Changed 5 years ago by vipsoft (robocoder)

This is dependent on various jQuery plugins being updated to support jQuery 1.3.x (which has introduced some compat busters).

http://docs.jquery.com/Release:jQuery_1.3#Upgrading

comment:3 Changed 5 years ago by vipsoft (robocoder)

fdd2div 1.0 plugin didn't support jQuery 1.2.6; we've sent our patch upstream but may have to forward port our local mods

comment:4 Changed 5 years ago by matt (mattab)

vipsoft, when you say "we've sent our patch upstream but may have to forward port our local mods" do you mean that you've emailed the authors the patch? or did you patch the fdddiv locally to make it work (as well as patching our local modifications from previous versions) ?

comment:5 Changed 5 years ago by vipsoft (robocoder)

Yes, there are upstream tickets for common bugs fixed in Piwik and local mods specific to Piwik (should upstream developers be interested in adopting). Yes, local mods were forward ported in the update to jQuery 1.2.6.

comment:6 Changed 5 years ago by matt (mattab)

  • Milestone changed from Features requests - after Piwik 1.0 to Stable release

increasing priority as for the stable release we shouldn't rely on libraries that depend on old Jquery versions; hopefully fdddiv can be updated to support jquery 1.3.x either by us or they will release a new release. vipsoft if you have any update on this please let us know!

comment:7 Changed 5 years ago by matt (mattab)

  • Priority changed from normal to major

comment:8 Changed 5 years ago by matt (mattab)

  • Type changed from Task to Bug

comment:9 Changed 5 years ago by vipsoft (robocoder)

  • Milestone changed from 4- Stable release to 2- DigitalVibes
  • Summary changed from Update to jquery 1.3.x, jqueryUI 1.6.x to Update to jquery 1.3.x, jqueryUI 1.7.x

In #243, we didn't touch ui.sortable.js or ui.mouse.js. (Code from circa Oct 2007. These have since been incorporated into jqueryUI.)

This is the regression found in #709 with IE7:

  • Flash widgets (e.g., "Last visits graph" and "Visits by server time") can no longer be dragged & dropped to change the layout; error console reports: Line 13, Char 2817, "Object doesn't support this property or method"
  • "Add a widget..." - the screen jumps when you mouseover "Visitor Settings" or "Visitors", making it difficult to select a widget
  • "Add a widget..." - mouseover "Example Widgets" and then "Piwik Changelog" - the preview window is too tall and it isn't scrollable; you can't access any controls to either add the widget to the dashboard or close the window; the Escape key doesn't work

comment:10 Changed 5 years ago by vipsoft (robocoder)

  • Owner set to vipsoft
  • Sensitive unset

comment:11 Changed 5 years ago by vipsoft (robocoder)

For Superfish, consider adding supersubs.js. This allows for variable width submenus. May help with some long translations.

comment:12 Changed 5 years ago by vipsoft (robocoder)

  • Description modified (diff)

Alternatively: replace superfish and separate the "navigation" and "breadcrumbs" functionality.

comment:13 Changed 5 years ago by vipsoft (robocoder)

  • Milestone changed from 2- DigitalVibes to 2 - Piwik 0.5

comment:14 Changed 5 years ago by vipsoft (robocoder)

  • Owner vipsoft deleted

comment:15 Changed 5 years ago by vipsoft (robocoder)

  • Owner set to vipsoft

comment:16 Changed 4 years ago by vipsoft (robocoder)

These are the backward compatibility problems identified so far with the update to jquery 1.3.2:

  • IE7: dashboard: drag & drop Flash widgets works _except_
    • during the drag, the widget displays an OFC error (unable to load data)
    • on drop, the chart is offset within the div until clicked (causing a reload)
  • IE7: 'Add a widget' - screen still jumps during mouseover (introduced with 1.2.6 update)
  • FF3: dashboard: drag & drop broken
    Error: [Exception... "Node cannot be inserted at the specified point in the hierarchy"  code: "3" nsresult: "0x80530003 (NS_ERROR_DOM_HIERARCHY_REQUEST_ERR)"  location: "http://localhost/libs/jquery/jquery.js?piwik=0.5 Line: 268"]
    Source File: http://localhost/libs/jquery/jquery.js?piwik=0.5
    Line: 268
    
  • FF3/Safari: feedback form; scrollbar(s) appear; worse in FF3 because submit button is obscured
  • FF3/IE7/Opera: left mouse down on submenu item, hover off, and release, leaves item in selected state

comment:17 Changed 4 years ago by vipsoft (robocoder)

Ok. Moving the non-jquery-specific issues to separate tickets.

comment:18 Changed 4 years ago by vipsoft (robocoder)

  • Resolution set to fixed
  • Status changed from new to closed

In [1553], fixes #510 - Update jquery.js

  • update jQuery to 1.3.2
  • add jquery-ui.js 1.7.2
  • move loading of external .css before scripts
  • remove ui.mouse.js
  • remove ui.sortable_modif.js

comment:19 Changed 4 years ago by vipsoft (robocoder)

In [1558], refs #510, refs #946 - remove sortable helper class (no longer used)

comment:20 Changed 4 years ago by vipsoft (robocoder)

In [1565], refs #510 - deprecated '[@id=IDVALUE]' changed to '#IDVALUE'

Note: See TracTickets for help on using tickets.