Opened 5 years ago

Closed 2 years ago

Last modified 16 months ago

#536 closed New feature (fixed)

Add Loyalty report "Visitors who visited the website 1 time, 2 times, etc."

Reported by: matt Owned by:
Priority: major Milestone: 1.12.x - Piwik 1.12.x
Component: Core Keywords:
Cc: Sensitive: no

Description (last modified by matt)

  • Loyalty: M people visited N times

See

We probably need to keep track of the count of visits for each visitor in a new table, to be able to tell this stat on more than 1 day range.

Change History (13)

comment:1 Changed 5 years ago by matt (mattab)

  • Description modified (diff)

comment:2 Changed 5 years ago by matt (mattab)

  • Type changed from Task to New feature

comment:3 Changed 5 years ago by koteiko

comment:4 Changed 4 years ago by matt (mattab)

  • Milestone changed from 4 - Piwik 1.0 - Stable release to Features requests - after Piwik 1.0
  • Sensitive unset

comment:6 Changed 3 years ago by matt (mattab)

  • Description modified (diff)
  • Priority changed from major to normal
  • Summary changed from Add Loyalty and Recency reports to Add Loyalty report "Visitors who visited the website 1 time, 2 times, etc."

Moved Recency report requirement in #583

comment:7 Changed 3 years ago by matt (mattab)

  • Milestone changed from Feature requests to 1.3 - Piwik 1.3
  • Priority changed from normal to major

This is also easy to implement now, because log_visit contains the field piwik_log_visit.visitor_count_visits which is the count of visits. This is set using the first party cookies counter. We can therefore query GROUP by this field and get the report.

The GA breakdown is as follows:

Count of visits from this visitor including current Visits that were the visitor's nth visit Percentage of all visits

Count of visits from this visitor including current 	Visits that were the visitor's nth visit
1 times 	179,528.00 	
2 times 	16,412.00 	
3 times 	6,006.00 	
4 times 	3,389.00 	
5 times 	2,371.00 	
6 times 	1,819.00 	
7 times 	1,469.00 	
8 times 	1,236.00 	
9-14 times 	4,590.00 	
15-25 times 	3,997.00 	
26-50 times 	3,880.00 	
51-100 times 	2,665.00 	
101-200 times 	958.00 	
201+ times 	1,481.00 	

We can reuse the same breakdown as it is relevant and consistent. See also similar #584, #2031

comment:8 Changed 3 years ago by capedfuzz (diosmosis)

Got a question about this issue: where would this specific report be placed? Thanks in advance.

comment:9 Changed 3 years ago by matt (mattab)

where would this specific report be placed?

I would say Visitor > Engagement report page (already built using 2 plugins outputs).

comment:10 Changed 2 years ago by matt (mattab)

  • Resolution set to fixed
  • Status changed from new to closed

(In [5378]) Fixes #584, #536, #2031 - Kuddos to Benaka akka capedfuzz for this great patch!!! I did a few minor modifications in wording and metadata output

  • Add Report "Visits by visit number" under Visitors > Engagement
  • Add Report for all Goals (including ecommerce): "Visit until Conversion": number of visits until the conversion occured
  • Add Report for all Goals (including ecommerce): "Days until Conversion": days since the first visit

Notes

  • These new reports are also in the Metadata API so should be displayed in Piwik Mobile, and can be exported in the Scheduled reports.
  • filter_only_idgoal now renamed as idGoal for consistency
  • refactored the "Beautify labels" for ranges in generic filters
  • refactored archiving code to process multiple reports in one generic SQL query

comment:11 Changed 2 years ago by JulienM (JulienMoumne)

It seems Visitors > Engagement > "Visits by visit number" column titles are not clickable/sortable, is it by design ?

The other two reports are ok.

comment:12 Changed 2 years ago by capedfuzz (diosmosis)

I disabled sorting for that report since the other two VisitorInterest reports also disable it. I don't know if this is the desired behavior, but I could make some changes when I submit a patch for #583 (shouldn't be too long now...).

comment:13 Changed 16 months ago by matt (mattab)

  • Milestone changed from 1.8.x Piwik 1.8.x to 1.9.x - Piwik 1.9.x

Milestone 1.8.x Piwik 1.8.x deleted

Note: See TracTickets for help on using tickets.