Opened 5 years ago

Closed 5 years ago

#561 closed Bug (fixed)

Piwik_DataTable_Renderer doesn't use the Piwik_API_Request $request parms

Reported by: chuckdeal97 Owned by:
Priority: major Milestone: RobotRock
Component: Core Keywords: Datatable renderer
Cc: Sensitive:

Description

Using this query string, I am trying to get back the full expanded datatable in the php array. CorpspediaActions.getActionsFilteredByUser is an extension of Actions that does its own archive processing based upon the original methods (essentially grouping by a custom user_id field).

module=API&method=CorpspediaActions.getActionsFilteredByUser&token_auth=bea1c80a75f6bc12582459358d79a9fc&date=last10&period=day&idsite=1&expanded=true&format=php&idSite=1

I expected the "expanded" property to cause the php array to come back full loaded. But it was not, using a debugger, I can verify that the table and subtables ARE being built, but it is the rendering process that is not including the subtables in the final response.

The problem appears to be caused by the fact that the Piwik_API_Request builds a custon "request" array that it passes to the Piwik_API_ResponseBuilder (who eventually will handle the rendering). The problem is that in the constructor for Piwik_DataTable_Renderer, it doesn't have access to the custom request array and therefore does not find the expanded parm that was set to "true".

My gut tells me that we need to find a way to propagate the custom request array to the Renderer so that it can use that array (when available) instead of the plain $_REQUEST array (which is the default).

Change History (4)

comment:1 Changed 5 years ago by chuckdeal97

I am going to try and hack a solution so I can solve my immediate needs, but I hope that you can help with a more elegant solution. Thanks!

comment:2 Changed 5 years ago by vipsoft (robocoder)

  • Milestone set to Features requests - after Piwik 1.0

comment:3 Changed 5 years ago by matt (mattab)

  • Milestone changed from Features requests - after Piwik 1.0 to RobotRock

it's actually a bug, and could be a limitation for people building plugin. increasing priority.

comment:4 Changed 5 years ago by matt (mattab)

  • Resolution set to fixed
  • Status changed from new to closed

fixed in [944]

refactored and added public method to set all customizations on the Renderer + updating tests

please svn up, test, and if still experience problems please reopen

Note: See TracTickets for help on using tickets.