Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#590 closed Bug (fixed)

Doesn't display Graphs with IE 7.x / Access via HTTPS

Reported by: Dawn Owned by:
Priority: major Milestone: Piwik 0.6.1
Component: Core Keywords: graph, plugin, display
Cc: Sensitive:

Description

When I access Piwik via HTTPS with Internet Explorer, some graphs aren't displayed. Instead of the Graph there is only the URL shown. This occures with the plugins "Last unique visitors graph", "Last visits graph", "Visitor continents", "Browse by family" and "List of plugins".

Attachments (2)

screenshot.jpg (162.6 KB) - added by Dawn 5 years ago.
A screenshot of the problem
590.diff (581 bytes) - added by vipsoft 5 years ago.

Download all attachments as: .zip

Change History (14)

Changed 5 years ago by Dawn

A screenshot of the problem

comment:1 Changed 5 years ago by Dawn

This occures since the beginning and with the latest version 0.2.32 too.

comment:2 Changed 5 years ago by vipsoft (robocoder)

  • Component changed from Plugins to Core
  • Milestone set to RobotRock

Dupes ticket #550.

comment:3 Changed 5 years ago by matt (mattab)

vipsoft, is it dupe? does that mean that the ticket shouldn't have been closed?

dawn, can you please provide URL to the ssl piwik instance with no showing graphs?

comment:4 Changed 5 years ago by vipsoft (robocoder)

I believe the proposed patch for #550 would have applied to all dynamic content. In comparison, the modified patch doesn't appear to take into account API requests, e.g., the data= URL for OFC flash graphs, like:

http://piwik.org/demo/index.php?module=VisitsSummary&action=getLastVisitsGraph&idSite=1&period=day&date=2009-02-08%2C2009-03-09&viewDataTable=generateDataChartEvolution

comment:5 Changed 5 years ago by vipsoft (robocoder)

  • Milestone changed from RobotRock to DigitalVibes

See also #646

Changed 5 years ago by vipsoft (robocoder)

comment:6 Changed 5 years ago by vipsoft (robocoder)

  • Resolution set to fixed
  • Status changed from new to closed

(In [1088]) Fixes #590 - use relative path

comment:7 Changed 5 years ago by matt (mattab)

(In [1089]) - refs #590 without the / in /libs/... the path is wrong on my windows box (missing the /)

comment:8 Changed 5 years ago by vipsoft (robocoder)

  • Resolution fixed deleted
  • Status changed from closed to reopened

[1089] breaks on my Linux box ... re-opening until we get this one right

comment:9 Changed 5 years ago by vipsoft (robocoder)

Matt: can you test the fix in [1092] on your Windows box?

comment:10 Changed 5 years ago by matt (mattab)

vipsoft, works fine!

comment:11 Changed 5 years ago by vipsoft (robocoder)

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:12 Changed 5 years ago by vipsoft (robocoder)

(In [1242]) refs #691, refs #590 - fix regression with Flash over https with IE

Note: See TracTickets for help on using tickets.