Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#593 closed Bug (fixed)

Zend require_once path fix

Reported by: vipsoft Owned by:
Priority: normal Milestone: RobotRock
Component: Core Keywords:
Cc: Sensitive:

Description

In libs/Zend/Registry.php (line 146), replace:

require_once 'Exception.php';

with

require_once 'Zend/Exception.php';

(This is fixed in later versions of ZF.)

Change History (5)

comment:1 Changed 5 years ago by vipsoft (robocoder)

  • Milestone set to RobotRock

comment:2 Changed 5 years ago by matt (mattab)

  • Resolution set to fixed
  • Status changed from new to closed

fixed in [974]

vipsoft, do you know of any blocker to update all the zend files used in Piwik?

btw as a side note, I am thinking of migrating to use Zend_Form later.

comment:3 Changed 5 years ago by vipsoft (robocoder)

With respect to #497 ? I haven't done the analysis yet on patches (eg which, if any, must be forward ported).

comment:4 Changed 5 years ago by spomoni

comment:5 Changed 5 years ago by spomoni

Note: See TracTickets for help on using tickets.