Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#648 closed Bug (invalid)

image broken with 0.2.33 update / visit tracking

Reported by: mvanlaar Owned by:
Priority: major Milestone: RobotRock
Component: Core Keywords:
Cc: Sensitive:

Description

The 1 x 1 pixel is broken, it gives a red cross on the webpages. Also piwik does not trakc any webvisits any more sinds the upgrade to 0.2.33.

Attachments (2)

piwiktrackingimage.jpg (4.3 KB) - added by mvanlaar 5 years ago.
Screenshot of not working piwik image in IE7
piwiktyperror.jpg (37.7 KB) - added by mvanlaar 5 years ago.
Good type with 03.32 with 0.3.33 and 0.3.34 text/html

Download all attachments as: .zip

Change History (23)

Changed 5 years ago by mvanlaar

Screenshot of not working piwik image in IE7

comment:2 Changed 5 years ago by matt (mattab)

  • Milestone set to RobotRock

what's the website url?

comment:3 Changed 5 years ago by mvanlaar

http://colombia.mvanlaar.net (at the bottum of the page)
http://www.mvanlaar.net (at the bottum of the page)
http://funstuff.mvanlaar.net (at the bottum of the page)

Al are on the same piwik installation. (http://stats.mvanlaar.net)

comment:4 Changed 5 years ago by mvanlaar

I've downgrade to 0.2.32 and all my problems went away. See the forum topic with new updates from other people.

comment:5 Changed 5 years ago by mvanlaar

The demo page of piwik also registerd yesterday no visitors. Wich is kind of odd. The demo page is also running 0.2.33. Perhaps you can look in you're logs to find the problems faster.

comment:6 Changed 5 years ago by matt (mattab)

  • Resolution set to fixed
  • Status changed from new to closed

(In [1061]) - fixed #648 due to wrong order in includes when regenerating cache file in piwik.php

comment:8 Changed 5 years ago by mvanlaar

  • Resolution fixed deleted
  • Status changed from closed to reopened

matthieu: I've installed 0.3.34, the problem still exist. The visit is not captured. With 0.3.32, i see a direct increase of the actions if I browse my sites. On 0.3.34 i don't see it. Also the method for showing the error (the extra faq item) isn't working for me. What is see in firefox with 0.3.32 see attachment.
The type with 0.3.32 is image/gif with 0.3.34 and 0.3.33 it is text/html that is the problem with the red cross. I see no errors printed on the webpage. It is possible because i use windows a my hosting platform.

Changed 5 years ago by mvanlaar

Good type with 03.32 with 0.3.33 and 0.3.34 text/html

comment:9 Changed 5 years ago by matt (mattab)

mvanlaar what's the url of your website with the image not loaded? please leave it online while we have a a look.

comment:10 Changed 5 years ago by mvanlaar

Alle sites at: 04/10/09 07:31:02. I've put 0.3.34 back online. It's a windows 2003 Server with IIS / FastCGI/PHP. PHP info is here: http://stats.mvanlaar.net/info.php.
I use the geoip plugin version 0.7. I've you want login details for piwik it is possible.

comment:11 Changed 5 years ago by matt (mattab)

piwik.php returns error 500; what does your IIS error.log mention?

comment:12 Changed 5 years ago by mvanlaar

PHP Error log:

[14-Apr-2009 11:24:53] PHP Fatal error: Uncaught exception 'Exception' with message 'Error query: SQLSTATE[HY000]: General error: 1364 Field 'location_geoip_continent' doesn't have a default value

In query: INSERT INTO piwik_log_visit (idsite, visitor_localtime, visitor_idcookie, visitor_returning, visit_first_action_time, visit_last_action_time, visit_server_date, visit_entry_idaction, visit_exit_idaction, visit_total_actions, visit_total_time, visit_goal_converted, referer_type, referer_name, referer_url, referer_keyword, config_md5config, config_os, config_browser_name, config_browser_version, config_resolution, config_pdf, config_flash, config_java, config_director, config_quicktime, config_realplayer, config_windowsmedia, config_cookie, location_ip, location_browser_lang, location_country, location_provider, location_continent) VALUES (?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?)
Parameters: array (

0 => '1',
1 => '11:24:53',
2 => '740507760a9103eff78eef4274c8dce8',
3 => 1,
4 => '2009-04-14 11: in D:\Webserver\stats.mvanlaar.net\htdocs\core\Tracker\Db.php on line 209

comment:13 Changed 5 years ago by mvanlaar

IIS only captures the 500 error logging. So on Windows system you need php error logging.

comment:14 Changed 5 years ago by mvanlaar

GeoIP was upgraded to 0.8 and disabled, error still exist.

comment:15 Changed 5 years ago by mvanlaar

The problem is sql query used to add the geoip plugin:

location_geoip_country location_geoip_continent, and location_geoip_city cannot be null.

If you add the plugin and then disable (or delete) is you get the error above. Why there is no data from the plugin i don't now.

comment:16 Changed 5 years ago by mvanlaar

sorry above message is also when you enable it.

comment:17 Changed 5 years ago by mvanlaar

I fixed it. The Geoip.dat was corrupted.

comment:18 Changed 5 years ago by matt (mattab)

  • Resolution set to invalid
  • Status changed from reopened to closed

ok will push update to geoip to make these fields NULLable

comment:19 Changed 5 years ago by alivenk

comment:20 Changed 5 years ago by domtop

comment:21 Changed 5 years ago by spomoni

Note: See TracTickets for help on using tickets.