Opened 5 years ago

Closed 5 years ago

#683 closed New feature (wontfix)

Add ability to disable plugin detection in piwik.js

Reported by: make-piw Owned by: vipsoft
Priority: normal Milestone: Piwik 0.6.1
Component: Core Keywords:
Cc: Sensitive:

Description

Hi folks,
since putting in Piwik(0.2.34) JS in one of our website I've noticed that it actually triggers the QuickTime PlugIn(QuickTime\qttask.exe) in IE6 which in return brings up my firewall alert box!
I guess it comes from Visitors->Settings->Plugins, so is there a way to disable this for a particular PlugIn?

Shouldn't these things under all circumstances be avoided and everything be carried out very discrete?
This may look like Piwik is snooping arround a bit to much in peoples computers, I'd say!

Change History (6)

comment:1 Changed 5 years ago by vipsoft (robocoder)

  • Milestone set to Features requests - after Piwik 1.0
  • Priority changed from critical to normal
  • Summary changed from Piwik JS triggers qttask.exe in IE6 and pers. Firewall Alert to Add ability to diable plugin detection in piwik.js
  • Type changed from Bug to New feature

This is currently by design. piwik.js tries to load the QuickTime helper ActiveX object to see if the plugin is installed. If I'm not mistaken, the firewall alert is probably triggering on "QT phone home", i.e., the QT plugin checks to see if there's a new version of the player available.

Note: more plugin detection is planned for #346.

comment:2 Changed 5 years ago by vipsoft (robocoder)

  • Summary changed from Add ability to diable plugin detection in piwik.js to Add ability to disable plugin detection in piwik.js

comment:3 Changed 5 years ago by make-piw

Yes, I understand it's "by design"… it's just, on a corporate level this will stop us using Piwik for now, unfortunately.
Any chance you could point me to the JS code to disable these PlugIn checks, please?
We'd be ok to have the whole PlugIn section not logging anything.

Thanks

comment:4 Changed 5 years ago by vipsoft (robocoder)

  • Milestone changed from Features requests - after Piwik 1.0 to DigitalVibes
  • Owner set to vipsoft
  • Status changed from new to assigned

In piwik.js, search for the string "Quicktime.Quicktime" and rename it to something like "Quicktimecheck.disabled". This leaves the plugin detection code intact for other plugins.

Alternately, change this function:

function _pk_plug_ie(dummy) { return false; }

to disable plugin detection on IE.

An upcoming release will have a new piwik.js.

comment:5 Changed 5 years ago by make-piw

This is excellent thank you so much
and good news for the future too — very much appreciated ;-)

comment:6 Changed 5 years ago by matt (mattab)

  • Resolution set to wontfix
  • Status changed from assigned to closed

won't provide plugin detection disable method.
but will kill quicktime detection all together

Note: See TracTickets for help on using tickets.