Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#742 closed Bug (fixed)

Open Flash Chart update

Reported by: vipsoft Owned by:
Priority: low Milestone: Piwik 0.4.1
Component: Core Keywords:
Cc: Sensitive:

Description

Now at OFC2 "Version 2 Jörmungandr".

Note: Flash Player 9 and up has a built-in file cache that isn't cleared when the browser cache is deleted. This became evident in the update from OFC1 to OFC2.

If we add a parameter to the URL to bust this cache, e.g.,

libs/open-flash-chart/open-flash-chart.swf?v2J

is it still cacheable?

Change History (8)

comment:1 Changed 5 years ago by vipsoft (robocoder)

  • Priority changed from major to normal

This ticket will just to be update OFC to v2J.

The cache issue may be invalid. Using FF3 and looking at my access.log, I see the .swf was fetched multiple times, corresponding with each chart widget on the dashboard.

comment:2 Changed 5 years ago by vipsoft (robocoder)

  • Resolution set to fixed
  • Status changed from new to closed

(In [1144]) fixes #742 - update to Open Flash Chart v2 J?\195?\182rmungandr; add cache
busting version string to core/ViewDataTable/GenerateGraphHTML.php

comment:3 Changed 5 years ago by vipsoft (robocoder)

  • Milestone changed from 1 - Piwik 0.4 to 2- DigitalVibes
  • Resolution fixed deleted
  • Status changed from closed to reopened

reverted in [1173] - reload() doesn't work anymore

comment:4 Changed 5 years ago by vipsoft (robocoder)

  • Status changed from reopened to new

Regression also exists in V2J-2 (May 26). Looks like there's a fix in the pipe.

http://forums.openflashchart.com/viewtopic.php?f=5&t=1082&start=10

comment:5 Changed 5 years ago by vipsoft (robocoder)

  • Owner vipsoft deleted

comment:6 Changed 5 years ago by vipsoft (robocoder)

  • Priority changed from normal to low

comment:7 Changed 5 years ago by vipsoft (robocoder)

  • Resolution set to fixed
  • Status changed from new to closed

(In [1236]) Fixes #742 - update to Open Flash Charts Version2 Kvasir; we skipped V2J
due to regressions

comment:8 Changed 5 years ago by vipsoft (robocoder)

  • Milestone changed from 2- DigitalVibes to 1 - Piwik 0.4.1
Note: See TracTickets for help on using tickets.