Opened 5 years ago

Closed 5 years ago

#785 closed Bug (fixed)

Bug the new piwik.js from Version 0.4 doesn't work with perfectlightbox

Reported by: Kibith Owned by:
Priority: major Milestone: Piwik 0.4.1
Component: Core Keywords: perfectlightbox typo3 piwik.js
Cc: Sensitive:

Description

Hello,

thank you for this realy good programm, it is quiet amazing.
I used version 0.2.37 and i cloud regonize no problems.
Since I use version 0.4 the perfectlightbox isnt functional in the beloved internet explorer 6, 7 and 8.....so you see my problem ;)
For technical information I use Typo3 4.2.6, Perfectlightbox extension "perfectlightbox" version 2.2.3 (an update to 2.2.4 is not the answer, I already try this)...

so, my farest workaround is to use the piwik.js from version 0.2.37.

Question:

  • can I use the older piwik.js in the new version without bigger problems?
  • is there a possibility that someone can fix the new piwik.js to fit with perfecctlightbox?
  • or is something else I can do for help or to solve the problem ?

I hope the is an answer out there ;)

Change History (5)

comment:1 Changed 5 years ago by Kibith

sorry, i forgot to mention the problem.....

perfectlightbox does anything but doing what it should do....

comment:2 Changed 5 years ago by vipsoft (robocoder)

I believe this is the same problem as reported for lightwindow.

Can you try this? Change your tracking code to load the unminified js/piwik.js; in that file, remove the "return true" from the end of the clickHandler function.

If that doesn't resolve the issue, I'll give you the code changes to lightbox.js.

comment:3 Changed 5 years ago by vipsoft (robocoder)

  • Milestone changed from 4- Stable release to 1 - Piwik 0.4.1

comment:4 Changed 5 years ago by Kibith

AMAZING, quiet amazing :)

yes, the problem is solved realy nice of you to answer so fast

(someone how has the right permission could close this ticket)

thank you very much

comment:5 Changed 5 years ago by vipsoft (robocoder)

  • Resolution set to fixed
  • Status changed from new to closed

(In [1211]) Fixes #785 - omit return value -- default action is implied
(accommodates IE's handling of poorly written JavaScript)

The right way to prevent the default action with multiple click
handlers:

element.onclick = function (e) {
	e = e || window.event;
	if (e.preventDefault)
		e.preventDefault();
	else
		e.returnValue = false;
	return false;
}
Note: See TracTickets for help on using tickets.