Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#869 closed Bug (fixed)

Openflashchart Error 2032 with SSL and Internet Explorer

Reported by: fuero Owned by: vipsoft
Priority: major Milestone: Piwik 0.4.2
Component: Core Keywords:
Cc: Sensitive: no

Description

I'm experiencing this issue (http://dwairi.wordpress.com/2009/01/15/open-flash-chart-ie-and-ssl) with piwik 0.4.1.
As indicated in the article, this only surfaces if SSL and IE are used.
Firefox, Safari and Opera are fine.

I attached a picture of the incident.

The URL seen in the picture is:

index.php?module=VisitsSummary&action=getEvolutionGraph&columns[]=nb_visits&idSite=1&period=day&date=2009-06-15,2009-07-14&viewDataTable=generateDataChartEvolution

As suggested in the blog article above, the following statements inserted in apache's config will fix this.

BrowserMatch MSIE HAVE_MSIE
Header set Expires       "Thu, 01 Jan 1970 01:00:00 GMT"        env=HAVE_MSIE
Header set Cache-Control "must-revalidate, cache, public"       env=HAVE_MSIE
Header set Pragma        "public"                               env=HAVE_MSIE

I couldn't pinpoint the culprit file, so I tried applying this to all (which works).

This shouldn't make a difference, but I have mod_rewrite rules in place to ensure SSL is used.

RewriteEngine On
RewriteRule   /piwik\.php|js)    -                        [L]
RewriteRule   (.*)               https://%{SERVER_NAME}$1 [R,L]

Attachments (2)

open-flash-chart-error.png (6.4 KB) - added by fuero 5 years ago.
vanilla-anon.txt (33.6 KB) - added by fuero 5 years ago.
trace from iehttpheaders

Download all attachments as: .zip

Change History (14)

Changed 5 years ago by fuero

comment:1 follow-up: Changed 5 years ago by vipsoft (robocoder)

  • Component changed from UI (templates, javascript) to Core
  • Owner set to vipsoft
  • Priority changed from normal to major

I can't reproduce this regression of #550 on my dev environment.

What version of php are you using?
Without your Apache config changes, what do the headers from your Piwik installation look like?

comment:2 in reply to: ↑ 1 Changed 5 years ago by fuero

Replying to vipsoft:

I can't reproduce this regression of #550 on my dev environment.

What version of php are you using?

PHP Version 5.1.6

Without your Apache config changes, what do the headers from your Piwik installation look like?

See the attached file - this is a trace of all requests and responses after clicking the login button.

Changed 5 years ago by fuero

trace from iehttpheaders

comment:3 Changed 5 years ago by vipsoft (robocoder)

Thanks.

It looks like our header changes aren't being applied in the data-file stream. (Lines 1038-1046 and 1060-1068.)

comment:4 Changed 5 years ago by vipsoft (robocoder)

(In [1306]) refs #869 - fix Flash+IE over HTTPS

comment:5 Changed 5 years ago by vipsoft (robocoder)

fuero: please test the patch.

comment:6 Changed 5 years ago by fuero

Tested with IE 7 and IE 8 on Windows XP, works as expected.

comment:7 Changed 5 years ago by vipsoft (robocoder)

  • Resolution set to fixed
  • Status changed from new to closed

Thanks.

comment:8 Changed 5 years ago by koteiko

comment:9 Changed 4 years ago by matt (mattab)

(In [1702]) Only send the 'https work in IE please' headers when in https mode, so that graphs are cached in non-ssl (better user experience when viewing multiSites dashboard) refs #869

comment:10 Changed 4 years ago by vipsoft (robocoder)

  • Resolution fixed deleted
  • Sensitive unset
  • Status changed from closed to reopened

THis appears to be a regression for reverse proxies where the backend server is http, and only the proxy is https.

comment:11 Changed 4 years ago by vipsoft (robocoder)

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [1705]) fixes #869 - Installation - detect presence of a reverse proxy and warn if mismatch with $_SERVERHTTPS?; add 'reverse_proxy' config setting

comment:12 Changed 4 years ago by vipsoft (robocoder)

  • Keywords IE open-flash-chart SSL HTTPS removed
Note: See TracTickets for help on using tickets.