Opened 5 years ago

Closed 5 years ago

#942 closed Bug (fixed)

Calendar should use the server date and time and not rely on browser settings

Reported by: matt Owned by:
Priority: major Milestone: Piwik 0.4.4
Component: Core Keywords:
Cc: Sensitive: no

Description

Currently, if your webserver is in GMT but your computer set to GMT-6, if you visit the calendar after 6PM you should be in the next day, but the calendar still shows today in GMT-6.

probably caused by the

			maxDate: new Date(),

in plugins/CoreHome/templates/calendar.js

Change History (5)

comment:1 Changed 5 years ago by vipsoft (robocoder)

Can we defer this and work on it conjunction with #56?

comment:2 Changed 5 years ago by vipsoft (robocoder)

  • Milestone changed from 1 - Piwik 0.4.4 to 2- DigitalVibes

comment:3 Changed 5 years ago by matt (mattab)

I believe this is independant of #56 and should be a quick fix (the JS should simply read the server side date rather than doing new Date()).

comment:4 Changed 5 years ago by matt (mattab)

  • Milestone changed from 2- DigitalVibes to 1 - Piwik 0.4.4

comment:5 Changed 5 years ago by vipsoft (robocoder)

  • Resolution set to fixed
  • Status changed from new to closed

In [1482], fixes #942 - calendar should use the server date for 'today'

Note: See TracTickets for help on using tickets.