Opened 5 years ago

Closed 5 years ago

Last modified 3 years ago

#975 closed Bug (fixed)

Piwik UI fails miserably when reloading after logged out

Reported by: joku Owned by:
Priority: normal Milestone: Piwik 0.4.4
Component: UI - UX (AngularJS, twig, less) Keywords:
Cc: Sensitive: no

Description

It seems that my previous ticket about same issue disappeared without trace.

Version information: 0.4.3. No additional plugins.

Steps to reproduce:
1) Open piwik and log in
2) Open same piwik to another browser tab. Logout
3) Go back to original browser tab and click dashboard

What is expected: clean redirect to login page.

What is happening: see attachment. Quite unclean login page (navigation is there and header row shows that user is logged in).

Attachments (1)

piwik-screenshot.png (28.8 KB) - added by joku 5 years ago.
Screenshot of UI fail

Download all attachments as: .zip

Change History (9)

Changed 5 years ago by joku

Screenshot of UI fail

comment:1 Changed 5 years ago by vipsoft (robocoder)

  • Resolution set to duplicate
  • Status changed from new to closed

Please read comments in #966. I couldn't reproduce your original test case with the latest code in SVN.

comment:2 Changed 5 years ago by vipsoft (robocoder)

  • Component changed from Core to UI (templates, javascript)
  • Resolution duplicate deleted
  • Status changed from closed to reopened

comment:3 Changed 5 years ago by vipsoft (robocoder)

  • Resolution set to fixed
  • Status changed from reopened to closed

In [1463], fixes #975 (refs #966) - redirect if ajax loaded section contains what appears to be the Login form

comment:4 Changed 5 years ago by vipsoft (robocoder)

Hack. Tested on FF3.

comment:5 Changed 4 years ago by vipsoft (robocoder)

In [1563], refs #975 - redirect if ajax loaded table contains what appears to be a document (hackish; see also [1463])

in contrast, displays 'no data' for Flash charts

comment:6 Changed 4 years ago by vipsoft (robocoder)

In [1564], refs #975 - less hackish (revert changes to datatable.js in [1563])

comment:7 Changed 3 years ago by matt (mattab)

(In [4682]) Update msg which would be displayed when a user logs out & then reload a page with a site that he can't access, refs #975

comment:8 Changed 3 years ago by matt (mattab)

(In [4683]) Fixes #2424 - Now there is a proper error message when user tries to reload dashboard for an invalid site (or after being logged out) so we can remove the reload() which causes this bug refs #975

Note: See TracTickets for help on using tickets.